OpenSSL is the backbone of secure Internet communication. It has two currently active and supported development branches: version 1.1.1 and version 3.0.

 

It has recently been discovered that all current versions of OpenSSL 3 (3.0.0 through the current 3.0.6) have a critical security vulnerability, and must be upgraded to a new version immediately.

 

Power Admin products are NOT affected by this. Our product OpenSSL usage is as follows:

 

PA Server Monitor – uses OpenSSL 1.1.1 (not affected)
PA Storage Monitor – uses OpenSSL 1.1.1 (not affected)
PA File Sight – uses OpenSSL 1.1.1 (not affected)
PA WatchDISK – does not use OpenSSL
PA-Ping – uses OpenSSL 1.1.1 (not affected)

 

Our utility programs are shown below:

 

PAExec – does not use OpenSSL
SIP-Ping – does not use OpenSSL
SpeedFan HTTP Agent – does not use OpenSSL

 

We have always, and will continue to take software security very seriously to ensure our products are as safe and robust as we can possibly make them.

Share →
(19)